Ubuntu, Subclipse, and JavaHL

If you get an error message like the following when using Subclipse (The Eclipse SVN plugin) on Ubuntu:

Failed to load JavaHL Library.

This means that your Ubuntu installation is missing the Java bindings for svn, to remedy this, install the relevant package:

sudo apt-get install libsvn-java

Add the following to your eclipse.ini after the line starting with -vmargs

-Djava.library.path=/usr/lib/jni

Restart Eclipse. An alternative solution is to reconfigure Subclipse to use the pure Java bindings provided by SVNKit, select the Window|Preferences menu option, then choose Team>SVN from the tree view in the left pane, then choose SVNKit for the Client setting under the SVN Interface heading.

Advertisements